// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<script\b[^>]*>[\s\S]*<\/script>").unwrap();
let string = "<body>
<temlate></template>
<script>
var str = `<script>var html='abc';</script>
<style></style>
`;
</script>
<style></style>
</body>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}