$re = '/<script\b[^>]*>[\s\S]*<\/script>/i';
$str = '<body>
<temlate></template>
<script>
var str = `<script>var html=\'abc\';</script>
<style></style>
`;
</script>
<style></style>
</body>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);