import re
regex = re.compile(r"<script\b[^>]*>[\s\S]*<\/script>", flags=re.IGNORECASE)
test_str = ("<body>\n"
" <temlate></template>\n"
" <script>\n"
" var str = `<script>var html='abc';</script>\n"
" <style></style>\n"
" `;\n"
" </script>\n\n"
" <style></style>\n"
"</body>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")