using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://
(?:www\.)?
((?:[a-z][a-z0-9-]*[a-z0-9]\.|[a-z]\.)+
(?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))";
string input = @"http://0.example.com
http://www.www.example.com
https://dash-dash.example.com
http://-dash.example.com
https://dash-.example.com
http://some.something.com
https://www.helloworld.com
http://apple.www.example.com
https://example-2.com
http://awww.example.com
TV.S1E01.mp4
ssh://example.com";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}