import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://\n"
+ "(?:www\\.)?\n"
+ "((?:[a-z][a-z0-9-]*[a-z0-9]\\.|[a-z]\\.)+\n"
+ " (?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))";
final String string = "http://0.example.com\n"
+ "http://www.www.example.com\n"
+ "https://dash-dash.example.com\n"
+ "http://-dash.example.com\n"
+ "https://dash-.example.com\n"
+ "http://some.something.com\n"
+ "https://www.helloworld.com\n"
+ "http://apple.www.example.com\n"
+ "https://example-2.com\n"
+ "http://awww.example.com\n"
+ "TV.S1E01.mp4\n"
+ "ssh://example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}