use strict;
my $str = 'http://0.example.com
http://www.www.example.com
https://dash-dash.example.com
http://-dash.example.com
https://dash-.example.com
http://some.something.com
https://www.helloworld.com
http://apple.www.example.com
https://example-2.com
http://awww.example.com
TV.S1E01.mp4
ssh://example.com';
my $regex = qr/https?://
(?:www\.)?
((?:[a-z][a-z0-9-]*[a-z0-9]\.|[a-z]\.)+
(?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}