import Foundation
let pattern = #"""
https?://
(?:www\.)?
((?:[a-z][a-z0-9-]*[a-z0-9]\.|[a-z]\.)+
(?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace])
let testString = #"""
http://0.example.com
http://www.www.example.com
https://dash-dash.example.com
http://-dash.example.com
https://dash-.example.com
http://some.something.com
https://www.helloworld.com
http://apple.www.example.com
https://example-2.com
http://awww.example.com
TV.S1E01.mp4
ssh://example.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)