$re = '/https?://
(?:www\.)?
((?:[a-z][a-z0-9-]*[a-z0-9]\.|[a-z]\.)+
(?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))/ix';
$str = 'http://0.example.com
http://www.www.example.com
https://dash-dash.example.com
http://-dash.example.com
https://dash-.example.com
http://some.something.com
https://www.helloworld.com
http://apple.www.example.com
https://example-2.com
http://awww.example.com
TV.S1E01.mp4
ssh://example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);