import re
regex = re.compile(r"""
https?://
(?:www\.)?
((?:[a-z][a-z0-9-]*[a-z0-9]\.|[a-z]\.)+
(?:[a-z][a-z0-9-]*[a-z0-9]|[a-z]))
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("http://0.example.com\n"
"http://www.www.example.com\n"
"https://dash-dash.example.com\n"
"http://-dash.example.com\n"
"https://dash-.example.com\n"
"http://some.something.com\n"
"https://www.helloworld.com\n"
"http://apple.www.example.com\n"
"https://example-2.com\n"
"http://awww.example.com\n"
"TV.S1E01.mp4\n"
"ssh://example.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")