import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+).(\\d+)(.*\\n*)*";
final String string = "15.000 <i class=\"fa fa-caret-square-o-down fa-fw text-red\" \n"
+ " data-toggle=\"tooltip\" data-placement=\"right\" \n"
+ " title=\"decrease 10.000 \"></i>";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}