// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d+).(\d+)(.*\n*)*").unwrap();
let string = "15.000 <i class=\"fa fa-caret-square-o-down fa-fw text-red\"
data-toggle=\"tooltip\" data-placement=\"right\"
title=\"decrease 10.000 \"></i>";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}