# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\/\/)[^@]*(@)/\1user:pass\2/gm;t' <<< "http_proxy=\"http://QQ@127.0.0.1:8080/\"
http://test1:test2@127.0.0.1:8080/
http_proxy=\"http://QQ@127.0.0.1:8080/
http://@127.0.0.1:8080/\""