const regex = new RegExp('(//)[^@]*(@)', 'gm')
const str = `http_proxy="http://QQ@127.0.0.1:8080/"
http://test1:test2@127.0.0.1:8080/
http_proxy="http://QQ@127.0.0.1:8080/
http://@127.0.0.1:8080/"`;
const subst = `\1user:pass\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);