// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(//)[^@]*(@)").unwrap();
let string = "http_proxy=\"http://QQ@127.0.0.1:8080/\"
http://test1:test2@127.0.0.1:8080/
http_proxy=\"http://QQ@127.0.0.1:8080/
http://@127.0.0.1:8080/\"";
let substitution = "\\1user:pass\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}