package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(//)[^@]*(@)`)
var str = `http_proxy="http://QQ@127.0.0.1:8080/"
http://test1:test2@127.0.0.1:8080/
http_proxy="http://QQ@127.0.0.1:8080/
http://@127.0.0.1:8080/"`
var substitution = "\1user:pass\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}