import re
regex = re.compile(r"(//)[^@]*(@)", flags=re.MULTILINE)
test_str = ("http_proxy=\"http://QQ@127.0.0.1:8080/\"\n"
"http://test1:test2@127.0.0.1:8080/\n"
"http_proxy=\"http://QQ@127.0.0.1:8080/\n"
"http://@127.0.0.1:8080/\"")
subst = "\\1user:pass\\2"
result = regex.sub(subst, test_str)
if result:
print(result)