#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\([a-zA-Z]+\(\d+\)\s*=\s*\d+\)"
Local $sString = "(text text (text) text)" & @CRLF & _
"(F(1) = 44)" & @CRLF & _
"(text text [text] text)" & @CRLF & _
"[text text (text) text]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")