package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([a-zA-Z]+\(\d+\)\s*=\s*\d+\)`)
var str = `(text text (text) text)
(F(1) = 44)
(text text [text] text)
[text text (text) text]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}