re = /\([a-zA-Z]+\(\d+\)\s*=\s*\d+\)/
str = '(text text (text) text)
(F(1) = 44)
(text text [text] text)
[text text (text) text]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end