using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([a-zA-Z]+\(\d+\)\s*=\s*\d+\)";
string input = @"(text text (text) text)
(F(1) = 44)
(text text [text] text)
[text text (text) text]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}