import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([a-zA-Z]+\\(\\d+\\)\\s*=\\s*\\d+\\)";
final String string = "(text text (text) text)\n"
+ "(F(1) = 44)\n"
+ "(text text [text] text)\n"
+ "[text text (text) text]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}