// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\([a-zA-Z]+\(\d+\)\s*=\s*\d+\)").unwrap();
let string = "(text text (text) text)
(F(1) = 44)
(text text [text] text)
[text text (text) text]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}