$re = '/\([a-zA-Z]+\(\d+\)\s*=\s*\d+\)/';
$str = '(text text (text) text)
(F(1) = 44)
(text text [text] text)
[text text (text) text]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);