use strict;
my $str = 'ep
ep#
ep/';
my $regex = qr/ep#?\/?/mp;
my $subst = 'eu/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";