import Foundation
let pattern = ##"ep#?\/?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ep
ep#
ep/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"eu/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)