# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?(<h2 itemprop="name">\s*<a.*?<\/h2>\s?|$)/$1/gis;t' <<< "<Лишний код>
<Лишний код>
<h2 itemprop=\"name\"><a href=\"https://site.ru/1page.html\">Page1</a></h2>
<Лишний код>
<Лишний код>
<Лишний код>
<h2 itemprop=\"name\"><a href=\"https://site.ru/2page.html\">Page2</a></h2>
<Лишний код>
<Лишний код>"