#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is).*?(<h2 itemprop="name">\s*<a.*?</h2>\s?|$)"
Local $sString = "<Лишний код>" & @CRLF & _
"<Лишний код>" & @CRLF & _
"<h2 itemprop="name"><a href="https://site.ru/1page.html">Page1</a></h2>" & @CRLF & _
"<Лишний код>" & @CRLF & _
"<Лишний код>" & @CRLF & _
"<Лишний код>" & @CRLF & _
"<h2 itemprop="name"><a href="https://site.ru/2page.html">Page2</a></h2>" & @CRLF & _
"<Лишний код>" & @CRLF & _
"<Лишний код>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)