import Foundation
let pattern = #".*?(<h2 itemprop="name">\s*<a.*?</h2>\s?|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/1page.html">Page1</a></h2>
<Лишний код>
<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/2page.html">Page2</a></h2>
<Лишний код>
<Лишний код>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)