use strict;
my $str = '<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/1page.html">Page1</a></h2>
<Лишний код>
<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/2page.html">Page2</a></h2>
<Лишний код>
<Лишний код>';
my $regex = qr~.*?(<h2 itemprop="name">\s*<a.*?</h2>\s?|$)~isp;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";