// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is).*?(<h2 itemprop="name">\s*<a.*?</h2>\s?|$)"#).unwrap();
let string = "<Лишний код>
<Лишний код>
<h2 itemprop=\"name\"><a href=\"https://site.ru/1page.html\">Page1</a></h2>
<Лишний код>
<Лишний код>
<Лишний код>
<h2 itemprop=\"name\"><a href=\"https://site.ru/2page.html\">Page2</a></h2>
<Лишний код>
<Лишний код>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}