const regex = new RegExp('.*?(<h2 itemprop="name">\\s*<a.*?</h2>\\s?|$)', 'gis')
const str = `<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/1page.html">Page1</a></h2>
<Лишний код>
<Лишний код>
<Лишний код>
<h2 itemprop="name"><a href="https://site.ru/2page.html">Page2</a></h2>
<Лишний код>
<Лишний код>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);