#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)(\w+):\s*" & @CRLF & _
"(" & @CRLF & _
""[^"]*",? # qualquer coisa entre aspas, vírgula opcional" & @CRLF & _
"|[^\n\w]+ # só pra pegar o [{ depois de options" & @CRLF & _
")"
Local $sString = " options: [{" & @CRLF & _
" value: "120"," & @CRLF & _
" id: "40"," & @CRLF & _
" title: "1400g"," & @CRLF & _
" name: "Tamanho: 123"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" value: "336"," & @CRLF & _
" id: "60"," & @CRLF & _
" title: "Chocolate"," & @CRLF & _
" name: "Sabor"" & @CRLF & _
" }" & @CRLF & _
" ]"
Local $sSubst = "\"$1\": $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)