using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+):\s*
(
""[^""]*"",? # qualquer coisa entre aspas, vírgula opcional
|[^\n\w]+ # só pra pegar o [{ depois de options
)";
string substitution = @"\""$1\"": $2";
string input = @" options: [{
value: ""120"",
id: ""40"",
title: ""1400g"",
name: ""Tamanho: 123""
},
{
value: ""336"",
id: ""60"",
title: ""Chocolate"",
name: ""Sabor""
}
]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}