// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(\w+):\s*
(
"[^"]*",? # qualquer coisa entre aspas, vírgula opcional
|[^\n\w]+ # só pra pegar o [{ depois de options
)"#).unwrap();
let string = " options: [{
value: \"120\",
id: \"40\",
title: \"1400g\",
name: \"Tamanho: 123\"
},
{
value: \"336\",
id: \"60\",
title: \"Chocolate\",
name: \"Sabor\"
}
]";
let substitution = "\\\"$1\\\": $2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}