const regex = /(\w+):\s*
(
"[^"]*",? # qualquer coisa entre aspas, vírgula opcional
|[^\n\w]+ # só pra pegar o [{ depois de options
)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+):\\s*
(
"[^"]*",? # qualquer coisa entre aspas, vírgula opcional
|[^\\n\\w]+ # só pra pegar o [{ depois de options
)', 'gm')
const str = ` options: [{
value: "120",
id: "40",
title: "1400g",
name: "Tamanho: 123"
},
{
value: "336",
id: "60",
title: "Chocolate",
name: "Sabor"
}
]`;
const subst = `\"$1\": $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);