import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+):\\s*\n"
+ "(\n"
+ "\"[^\"]*\",? # qualquer coisa entre aspas, vírgula opcional\n"
+ "|[^\\n\\w]+ # só pra pegar o [\\{ depois de options\n"
+ ")";
final String string = " options: [{\n"
+ " value: \"120\",\n"
+ " id: \"40\",\n"
+ " title: \"1400g\",\n"
+ " name: \"Tamanho: 123\"\n"
+ " },\n"
+ " {\n"
+ " value: \"336\",\n"
+ " id: \"60\",\n"
+ " title: \"Chocolate\",\n"
+ " name: \"Sabor\"\n"
+ " }\n"
+ " ]";
final String subst = "\\\"$1\\\": $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}