import Foundation
let pattern = ##"""
(\w+):\s*
(
"[^"]*",? # qualquer coisa entre aspas, vírgula opcional
|[^\n\w]+ # só pra pegar o [{ depois de options
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
options: [{
value: "120",
id: "40",
title: "1400g",
name: "Tamanho: 123"
},
{
value: "336",
id: "60",
title: "Chocolate",
name: "Sabor"
}
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\"$1\": $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)