const regex = /\s*\b[a-z]+[A-Z][a-zA-Z]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\b[a-z]+[A-Z][a-zA-Z]+\\b', 'gm')
const str = `I like strawBerries
I like Strawberries`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);