use strict;
my $str = 'I like strawBerries
I like Strawberries';
my $regex = qr/\s*\b[a-z]+[A-Z][a-zA-Z]+\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";