# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^#WAV\b.*(?:\R#WAV\b.*)*//gm;t' <<< "#WAV 001.wav
#WAV \"something\"
#WAV 21021029910291029.ogg
.....
#WAV 001.wav
#WAV \"something\"
#WAV 21021029910291029.ogg"