#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^#WAV\b.*(?:\R#WAV\b.*)*"
Local $sString = "#WAV 001.wav" & @CRLF & _
"#WAV "something"" & @CRLF & _
"#WAV 21021029910291029.ogg" & @CRLF & _
"....." & @CRLF & _
"#WAV 001.wav" & @CRLF & _
"#WAV "something"" & @CRLF & _
"#WAV 21021029910291029.ogg"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)