use strict;
my $str = '#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg
.....
#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg';
my $regex = qr/^#WAV\b.*(?:\R#WAV\b.*)*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";