re = /^#WAV\b.*(?:\R#WAV\b.*)*/m
str = '#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg
.....
#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result