package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#WAV\b.*(?:\R#WAV\b.*)*`)
var str = `#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg
.....
#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}