const regex = /^#WAV\b.*(?:\R#WAV\b.*)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#WAV\\b.*(?:\\R#WAV\\b.*)*', 'gm')
const str = `#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg
.....
#WAV 001.wav
#WAV "something"
#WAV 21021029910291029.ogg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);