// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^#WAV\b.*(?:\R#WAV\b.*)*").unwrap();
let string = "#WAV 001.wav
#WAV \"something\"
#WAV 21021029910291029.ogg
.....
#WAV 001.wav
#WAV \"something\"
#WAV 21021029910291029.ogg";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}