using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)";
string input = @"Paul Green
Paul
Pelè
paul
walker
johnny
Green";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}