// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)").unwrap();
let string = "Paul Green
Paul
Pelè
paul
walker
johnny
Green";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}