$re = '/^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)/mi';
$str = 'Paul Green
Paul
Pelè
paul
walker
johnny
Green';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);