package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)`)
var str = `Paul Green
Paul
Pelè
paul
walker
johnny
Green`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}